Firefox Java Problems

Overview:

Recent updates in Mozilla's security policy have caused some older versions of Java to be blocked/disabled. That issue can cause problems downloading the Java plugin in Firefox or using Java.

Firefox updated to version 52 and now I can't access an application that requires Java:

Firefox version 52 does not support Java. Try using another browser or download Mozilla's Extended Support Release (Firefox 52ESR). To prevent future updates, you can automatically disable updates in your browser settings.

A WVU site is being blocked when I use Firefox:

Mozilla occasionally runs a script that disables the versions of Java that Mozilla determines are potentially unsafe. This script disables all versions of Java deemed unsafe across all recent versions of Firefox

If you run into any problems caused by this, try completing the following steps:

  1. Open Firefox.

  2. From the top menu bar, click Tools.

  3. From the drop-down menu, select Add-ons.

  4. From the side menu, click Plugins.

  5. Locate the disabled version of Java or J2SE.

  6. Change Never Activate to Always Activate.

This will enable the Java plugin until the next time the script is run by Mozilla.

For more information, visit Mozilla's support site.

What version of Java should I have and how can I check?

View our Recommended Java Version article.

I'm receiving a "plugin is vulnerable" screen:

If you receive a screen that says "This plugin is vulnerable and should be updated," follow the steps below:

  1. Click Activate Java.

  2. A screen will pop up to let you know that Firefox has prevented the outdated Java plugin from running on the website you are trying to access.

  3. Click Allow and Remember.

  4. When the Security Warning screen appears, select the I accept the risk and want to run this application check box.

  5. Click Run.

How do I activate Java for one website?

If you have a trusted site that uses Java, and you need to use that site often, you can activate the Java plugin for that specific website.

  1. Click the plugin icon in the address bar (the icon may show as red or blue). A window will open.

  2. At the bottom of the window, click the drop-down arrow next to the Activate All Plugins.

  3. Click Always activate plugins for this site.

 

Details

Article ID: 7033
Created
Mon 6/22/15 9:13 AM
Modified
Mon 8/12/19 3:00 PM